Nvidia GTX 1050 WORKING ON THE CUPERTINO2 MOTHERBOARD AND BIOS 7.14

Here a step by step guide on how I got it working.

Method 1: Using 2 monitors (tested):
Materials:
       2 monitors
       1 VGA cable
       1 DVI Cable
       EVGA Nvidia GTX 1050 GPU
       EVGA DVD-rom GTX 1050 driver disk (it comes with the newGPU)
       PC with H-CUPERTINO2-H61-uA TX mother board (HP Pavilion P6-2119EL )
       Bios Version: AMI 7.14 (the 7.16 should work as well)
       OS: Windows 10

Step 1 - Install the graphic card:
       Disconnect the PC from the power
       Remove the old graphic card
       Insert the new GTX 1050

Step 2 - Connect the 2 monitors:
      Connect* the one monitor with the VGA cable to the integrated graphic INTEL HD.
      *Note: in the bacj of my tower pc the VGA plug to the integrated graphic was covered with a piece of plastic with the label "Do not remove". Obviously you do have to remove that...
      Connect the second monitor with the DVI cable to the GTX 1050
      Reconnect the PC to the power 

Step 3 - Bios Settings (this step might be unnecessary)
      Switch on the PC
      Enter in the Bios (on my PC you have to press Esc and then F10)
      Go to Bios menu: Advanced > PCI VGA Configuration
      Set "Intel VGA controller" as primary VGA device (NO the Nvidia)
      Save the settings and reboot

Step 4 - Install the EVGA GTX 1050 drivers
      At that point Windows 10 should start
      You will notice that only the monitor connected to the integrated VGA is working
      Insert the EVGA GTX 1050 DVD and start the graphic driver installation
      Wait
      Wait
      Wait
      After a lot of time, during the installation progress, the second monitor (the DVI - GTX 1050 one) will become alive!
      Wait until the driver installation is completed
      Power off the PC

Step 5 - unplug the VGA monitor
       At that point you can unplug the VGA monitor connected to the integrated graphic
       Switch the PC on, with the DVI monitor connected to the GTX 1050

Step 6 - Enjoy your new GTX 1050
       Enjoy your brand new graphic card fully working!!!!

Benchmark
I do not have an official benchmark number, and I don't even know how to get one....
But, the Train Simulator (that what the reason of the whole operation) was working @ 15-20 frmes per seconds with the old card, it's now working @ 60-80 fps!!! 

Final Notes:
1 - The method should work using one monitor only (but I didn't test that obviously:
        a - Connect it to the VGA integrated
        b - Install the EVGA 1050 driver
        c - Restart the PC with the monitor connected to the DVI - GTX 1050

2 - The method should work with the Bios v 1.16 as well since the change log reports only minor changes; YOU DON'T NEED THE BIOS V 8.XX (even because it is not available)


3 - The Bios settings change might be not necessary

Nessun commento: